ПриЗаписиФормыОбъектаСклонения (БСП)

Автор: 1С
ОбщийМодуль.СклонениеПредставленийОбъектов
БСП

При записи формы объекта склонения. Обработчик события ПриЗаписиНаСервере управляемой формы объекта для склонения.

// Обработчик события ПриЗаписиНаСервере управляемой формы объекта для склонения.
//
// Параметры:
//  Форма				 - ФормаКлиентскогоПриложения	 - форма объекта склонения.
//  Представление		 - Строка			 - Строка для склонения.
//  Объект				 - ОбъектСклонения	 - Объект для склонения.
//  ПараметрыСклонения	 - Структура		 - необязательный, дополнительные параметры склонения,
//  		см. СклонениеПредставленийОбъектовКлиентСервер.ПараметрыСклонения().
//
Процедура ПриЗаписиФормыОбъектаСклонения(Форма, Представление, Объект, ПараметрыСклонения = Неопределено) Экспорт

	Если Форма.ИзмененоПредставление Тогда
		СтруктураСклонений = ПросклонятьПредставлениеПоВсемПадежам(Представление, ПараметрыСклонения);
		Форма.Склонения = Новый ФиксированнаяСтруктура(СтруктураСклонений);
		Форма.ИзмененоПредставление = Ложь;
	КонецЕсли;
	
	Если ТипЗнч(Форма.Склонения) = Тип("ФиксированнаяСтруктура") Тогда
		ЗаписатьВРегистрСклонения(Представление, Объект, Форма.Склонения);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПоказатьСклонение (БСП)

ПередЗаписьюНаСервере (БСП)

ОткрытьФормуСклоненияЗавершение (БСП)

ПриЗаписиПредметаИзФормы (БСП)

ПриСозданииНаСервере (БСП)

ДанныеОбновленыНаНовуюВерсиюПрограммы (БСП)

НачатьСклонение (БСП)

ЗавершитьСклонение (БСП)

TurboConf - расширение Конфигуратора 1С