ЭтоЭлементДинамическогоСписка (БСП)

Автор: 1С
ОбщийМодуль.СтандартныеПодсистемыКлиент
БСП

Это элемент динамического списка. Проверяет, что текущие данные определены и не являются группировкой.

// Проверяет, что текущие данные определены и не являются группировкой.
// Предназначена для обработчиков таблиц формы динамических списков.
//
// Параметры:
//  ТаблицаИлиТекущиеДанные - ТаблицаФормы - таблица формы динамического списка для проверки текущих данных.
//                          - Неопределено, ДанныеФормыСтруктура, Структура - текущие данные для проверки.
//
// Возвращаемое значение:
//  Булево.
//
Функция ЭтоЭлементДинамическогоСписка(ТаблицаИлиТекущиеДанные) Экспорт
	
	Если ТипЗнч(ТаблицаИлиТекущиеДанные) = Тип("ТаблицаФормы") Тогда
		ТекущиеДанные = ТаблицаИлиТекущиеДанные.ТекущиеДанные;
	Иначе
		ТекущиеДанные = ТаблицаИлиТекущиеДанные;
	КонецЕсли;
	
	Если ТипЗнч(ТекущиеДанные) <> Тип("ДанныеФормыСтруктура")
	   И ТипЗнч(ТекущиеДанные) <> Тип("Структура") Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Если ТекущиеДанные.Свойство("ГруппировкаСтроки") Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Возврат Истина;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УстановитьЭлементОтбораДинамическогоСписка (БСП)

УдалитьЭлементыГруппыОтбораДинамическогоСписка (БСП)

ДобавитьОтборыВСписокФайлов (БСП)

ОтборДинамическогоСписка (БСП)

СтруктураСвойствДинамическогоСписка (БСП)

НастроитьОтборыДинамическогоСписка (БСП)

УстановитьСвойстваДинамическогоСписка (БСП)

Получение данных динамического списка

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз