ПреобразоватьСтрокуВДопустимоеНаименованиеКолонки (БСП)

Автор: 1С
ОбщийМодуль.СтандартныеПодсистемыСервер
БСП

Преобразовать строку допустимое наименование колонки. Преобразует строку в допустимое наименование колонки таблицы значений, заменяя недопустимые

// Преобразует строку в допустимое наименование колонки таблицы значений, заменяя недопустимые
// символы на код символа ограниченного символом подчеркивания.
//
// Параметры:
//  Строка - Строка - Строка для преобразования.
// 
// Возвращаемое значение:
//  Строка - Строка, содержащая только допустимые символы для наименования колонок таблицы значений.
//
Функция ПреобразоватьСтрокуВДопустимоеНаименованиеКолонки(Строка) Экспорт
	
	НедопустимыеСимволы = ":;!@#$%^&-~`'.,?{}[]+=*/|\ ()_""";
	Результат = "";
	Для Индекс = 1 По СтрДлина(Строка) Цикл
		Символ =  Сред(Строка, Индекс, 1);
		Если СтрНайти(НедопустимыеСимволы, Символ) > 0 Тогда
			Результат = Результат + "_" + КодСимвола(Символ) + "_";
		Иначе
			Результат = Результат + Символ;
		КонецЕсли;
	КонецЦикла;
	
	Возврат Результат;
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПреобразоватьАдаптированноеНаименованиеКолонкиВСтроку (БСП)

ЭтоДопустимаяСсылка (БСП)

Преобразовать строку в дату

Преобразовать строку в число

Преобразовать строку таблицы значений в структуру

Колонки в строку

ПреобразоватьСтрокуВСписокПолей (БСП)

ПутьКТабличнойЧасти (БСП)

ПроверитьДанные (БСП)

TurboConf - расширение Конфигуратора 1С