УстановитьПустуюФормуНаПустойРабочийСтол (БСП)

Автор: 1С
ОбщийМодуль.СтандартныеПодсистемыСервер
БСП

Установить пустую форму на пустой рабочий стол. Устанавливает общую форму ПустойРабочийСтол на рабочий стол с пустым составом форм.

// Устанавливает общую форму ПустойРабочийСтол на рабочий стол с пустым составом форм.
//
// Для корректного отображения разделенного рабочего стола в веб-клиенте
// неразделенный рабочий стол должен иметь не пустой состав форм, и наоборот.
//
Процедура УстановитьПустуюФормуНаПустойРабочийСтол() Экспорт
	
	КлючОбъекта = "Общее/НастройкиНачальнойСтраницы";
	
	ТекущиеНастройки = ХранилищеСистемныхНастроек.Загрузить(КлючОбъекта);
	Если ТекущиеНастройки = Неопределено Тогда
		ТекущиеНастройки = Новый НастройкиНачальнойСтраницы;
	КонецЕсли;
	
	ТекущийСоставФорм = ТекущиеНастройки.ПолучитьСоставФорм();
	
	Если ТекущийСоставФорм.ЛеваяКолонка.Количество() = 0
	   И ТекущийСоставФорм.ПраваяКолонка.Количество() = 0 Тогда
		
		ТекущийСоставФорм.ЛеваяКолонка.Добавить("ОбщаяФорма.ПустойРабочийСтол");
		ТекущиеНастройки.УстановитьСоставФорм(ТекущийСоставФорм);
		ХранилищеСистемныхНастроек.Сохранить(КлючОбъекта, "", ТекущиеНастройки);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УстановитьПустуюФормуНаРабочийСтол (БСП)

СкрытьРабочийСтолПриНачалеРаботыСистемы (БСП)

ИдентификаторРабочегоСтола (БСП)

СформироватьСписокНовостейНаРабочийСтол (БСП)

ПриОпределенииПараметровФункциональныхОпцийИнтерфейса (БСП)

УстановитьРабочуюДатуПользователя (БСП)

УстановитьРабочийКаталогПользователя (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз