ДобавитьЗанятуюЛицензию (БСП)

Автор: 1С
ОбщийМодуль.ТарификацияСлужебный
БСП

Добавить занятую лицензию.

Функция ДобавитьЗанятуюЛицензию(Знач ДанныеОЛицензии, СтароеСостояниеЛицензии = "") Экспорт
	
	Услуга = Тарификация.УслугаПоИдентификаторуИИдентификаторуПоставщика(ДанныеОЛицензии.ServiceID,
		ДанныеОЛицензии.ServiceProviderID, Истина);
	
	Запись = РегистрыСведений.ЗанятыеЛицензии.СоздатьМенеджерЗаписи();
	Запись.Услуга = Услуга;
	Запись.ИдентификаторЛицензии = ДанныеОЛицензии.ID;
	Запись.КонтекстЛицензии = ДанныеОЛицензии.LicenseContext;
	Запись.Прочитать();
	Если Запись.Выбран() Тогда
		СтароеСостояниеЛицензии = Запись.НомерПодписки;
	Иначе
		Запись.Услуга = Услуга;
		Запись.ИдентификаторЛицензии = ДанныеОЛицензии.ID;
		Запись.КонтекстЛицензии = ДанныеОЛицензии.LicenseContext;
	КонецЕсли;
	
	Если ТипЗнч(ДанныеОЛицензии.SubscriptionEndDate) = Тип("Строка") Тогда
		 ДатаОтключенияПодписки = XMLЗначение(Тип("Дата") ,ДанныеОЛицензии.SubscriptionEndDate);
	ИначеЕсли ТипЗнч(ДанныеОЛицензии.SubscriptionEndDate) = Тип("Дата") Тогда
		 ДатаОтключенияПодписки = ДанныеОЛицензии.SubscriptionEndDate;
	Иначе
		ДатаОтключенияПодписки = Неопределено;
	КонецЕсли;
	
	Запись.НомерПодписки = ДанныеОЛицензии.SubscriptionCode;
	Запись.ДатаОтключенияПодписки = ДатаОтключенияПодписки;
	Запись.ДатаИзменения = ТекущаяДатаСеанса();
	УстановитьПривилегированныйРежим(Истина);
	Запись.Записать();
	УстановитьПривилегированныйРежим(Ложь);
	
	Возврат Запись;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УдалитьЗанятуюЛицензию (БСП)

КоличествоЗанятыхФайлов (БСП)

Добавить (БСП)

СвойстваЛицензии (БСП)

ОбновитьДанныеПоЛицензиям (БСП)

УдалитьДанныеПоЛицензиям (БСП)

КоличествоФайловЗанятыхТекущимПользователем (БСП)

СтрокаСообщенияОНедопустимостиПодписанияЗанятогоФайла (БСП)

TurboConf - расширение Конфигуратора 1С