ОбработкаОповещенияИзмененияФлажкаУдалятьПоРасписанию (БСП)

Автор: 1С
ОбщийМодуль.УдалениеПомеченныхОбъектовКлиент
БСП

Обработка оповещения изменения флажка удалять по расписанию. Обработчик события ОбработкаОповещения для формы, на которой требуется отобразить флажок удаления по расписанию.

// Обработчик события ОбработкаОповещения для формы, на которой требуется отобразить флажок удаления по расписанию.
//
// Параметры:
//   ИмяСобытия - Строка - имя события, которое было получено обработчиком события на форме.
//   АвтоматическиУдалятьПомеченныеОбъекты - Число - Реквизит, в которое будет помещено значение.
// 
// Пример:
//	Если ОбщегоНазначенияКлиент.ПодсистемаСуществует("СтандартныеПодсистемы.УдалениеПомеченныхОбъектов") Тогда
//		МодульУдалениеПомеченныхОбъектовКлиент = ОбщегоНазначенияКлиент.ОбщийМодуль("УдалениеПомеченныхОбъектовКлиент");
//		МодульУдалениеПомеченныхОбъектовКлиент.ОбработкаОповещенияИзмененияФлажкаУдалятьПоРасписанию(
//			ИмяСобытия, 
//			АвтоматическиУдалятьПомеченныеОбъекты);
//	КонецЕсли;
//
Процедура ОбработкаОповещенияИзмененияФлажкаУдалятьПоРасписанию(Знач ИмяСобытия, АвтоматическиУдалятьПомеченныеОбъекты) Экспорт
	
	Если ИмяСобытия = "ИзменилсяРежимАвтоматическиУдалятьПомеченныеОбъекты" Тогда
		АвтоматическиУдалятьПомеченныеОбъекты = 
			УдалениеПомеченныхОбъектовСлужебныйВызовСервера.ЗначениеФлажкаУдалятьПоРасписанию();
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПриИзмененииФлажкаУдалятьПоРасписанию (БСП)

ЗначениеФлажкаУдалятьПоРасписанию (БСП)

ОбработкаОповещенияИзмененияФлажкаИспользоватьПоиск (БСП)

ОбработкаОповещенияИзмененияФлажкаХранитьИсторию (БСП)

ОбработатьОповещениеОбИзменении (БСП)

ПриИзмененииРасписания (БСП)

ОповещениеОбИзменении (БСП)

ОповещенияОбИзмененияхНеИспользуются (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз