ОтправитьЗагрузитьПочтуПользователяЗавершение (БСП)

Автор: 1С
ОбщийМодуль.УправлениеЭлектроннойПочтойКлиент
БСП

Отправить загрузить почту пользователя завершение.

Процедура ОтправитьЗагрузитьПочтуПользователяЗавершение(Результат, ДополнительныеПараметры) Экспорт
	
	Если Результат = Неопределено Тогда
		Возврат;
	ИначеЕсли Результат.Статус = "Ошибка" Тогда
		ВызватьИсключение Результат.КраткоеПредставлениеОшибки;
	ИначеЕсли Результат.Статус = "Выполнено" Тогда
		
		РезультатВыполнения = ВзаимодействияВызовСервера.РезультатОтправкиПолученияПочтыПользователя(Результат.АдресРезультата);
		Если РезультатВыполнения = Неопределено Тогда
			Возврат;
		КонецЕсли;
		
		Если ДополнительныеПараметры.Свойство("ЭлементСписок")
			И ДополнительныеПараметры.ЭлементСписок <> Неопределено Тогда
			ДополнительныеПараметры.ЭлементСписок.Обновить();
		КонецЕсли;
		
		ТекстСообщения = ПредставлениеРезультатаОтправкиПолученияПисемПользователя(РезультатВыполнения);
		ПоказатьОповещениеПользователя(ТекстСообщения);
	
		Если РезультатВыполнения.ЕстьОшибки Тогда
	
			ОбщегоНазначенияКлиент.СообщитьПользователю(
				НСтр("ru = 'При получении почты были ошибки. Подробности см. в журнале регистрации'"));
	
		КонецЕсли;
		
		Оповестить("ВыполненаОтправкаПолучениеПисем");
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОтправитьЗагрузитьПочтуПользователя (БСП)

ОтправитьПолучитьПочтуПользователяВФоне (БСП)

Отправка Интернет Почты

ОтправитьФайлыПоПочте (БСП)

ОтправитьФайлыПоПочтеНастройкаУчетнойЗаписиПредложена (БСП)

РезультатОтправкиПолученияПочтыПользователя (БСП)

ОпределитьАдресЭлектроннойПочтыПользователя (БСП)

ЗагрузитьПользователейИнформационнойБазы (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз