ПреобразоватьСтрокуВСписокПолей (БСП)

Автор: 1С
ОбщийМодуль.УправлениеКонтактнойИнформациейСлужебный
БСП

Преобразовать строку список полей. Возвращает список значений. Преобразует строку полей в список значений.

// Возвращает список значений. Преобразует строку полей в список значений.
//
// Параметры:
//    СтрокаПолей - Строка - строка полей.
//
// Возвращаемое значение:
//    СписокЗначений - список значений полей.
//
Функция ПреобразоватьСтрокуВСписокПолей(СтрокаПолей) Экспорт
	
	// XML сериализацию преобразовывать не надо.
	Если УправлениеКонтактнойИнформациейКлиентСервер.ЭтоКонтактнаяИнформацияВXML(СтрокаПолей) Тогда
		Возврат СтрокаПолей;
	КонецЕсли;
	
	Результат = Новый СписокЗначений;
	
	СтруктураЗначенийПолей = СтруктураЗначенийПолей(СтрокаПолей);
	Для каждого ЗначениеПоля Из СтруктураЗначенийПолей Цикл
		Результат.Добавить(ЗначениеПоля.Значение, ЗначениеПоля.Ключ);
	КонецЦикла;
	
	Возврат Результат;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

Преобразовать строку в дату

Преобразовать строку в число

ПреобразоватьАдаптированноеНаименованиеКолонкиВСтроку (БСП)

Преобразовать строку таблицы значений в структуру

Поле планировщика Иерархический список

СтрокаПолей (БСП)

НомерТелефонаВСтарыйСписокПолей (БСП)

ПреобразоватьСтрокуВДопустимоеНаименованиеКолонки (БСП)

ЗаполнитьСписокВыбораДляРассмотретьПосле (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз