УстановитьПараметрыНабораСвойств (БСП)

Автор: 1С
ОбщийМодуль.УправлениеСвойствами
БСП

Установить параметры набора свойств. Устанавливает параметры набора свойств.

// Устанавливает параметры набора свойств.
//
// Параметры:
//  ИмяНабораСвойств - Строка - имя предопределенного набора свойств.
//  Параметры - Структура - см. описание функции СтруктураПараметровНабораСвойств.
//
Процедура УстановитьПараметрыНабораСвойств(ИмяНабораСвойств, Параметры = Неопределено) Экспорт
	
	Если Параметры = Неопределено Тогда
		Параметры = СтруктураПараметровНабораСвойств();
	КонецЕсли;
	
	ЗаписатьОбъект = Ложь;
	НаборСвойств = НаборСвойствПоИмени(ИмяНабораСвойств);
	Если НаборСвойств = Неопределено Тогда
		НаборСвойств = Справочники.НаборыДополнительныхРеквизитовИСведений[ИмяНабораСвойств];
	КонецЕсли;
	НаборСвойствОбъект = НаборСвойств.ПолучитьОбъект();
	Для Каждого Параметр Из Параметры Цикл
		Если НаборСвойствОбъект[Параметр.Ключ] = Параметр.Значение Тогда
			Продолжить;
		КонецЕсли;
		ЗаписатьОбъект = Истина;
	КонецЦикла;
	
	Если ЗаписатьОбъект Тогда
		ЗаполнитьЗначенияСвойств(НаборСвойствОбъект, Параметры);
		ОбновлениеИнформационнойБазы.ЗаписатьДанные(НаборСвойствОбъект);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СтруктураПараметровНабораСвойств (БСП)

НаименованияНаборовСвойств (БСП)

УстановитьОбменДаннымиЗагрузка (БСП)

НаборСвойствПоИмени (БСП)

ПредопределенныеНаборыСвойств (БСП)

СоздатьПредопределенныеНаборыСвойств (БСП)

ОбновитьНаименованияНаборовИСвойств (БСП)

ПриПолученииПредопределенныхНаборовСвойств (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз