ОтчетПодключенКФормеНастроек (БСП)

Автор: 1С
ОбщийМодуль.ВариантыОтчетов
БСП

Отчет подключен форме настроек. Определяет подключен-ли отчет к общей форме настроек отчета.

// Определяет подключен-ли отчет к общей форме настроек отчета.
Функция ОтчетПодключенКФормеНастроек(ОтчетМетаданные, ПоУмолчаниюВсеПодключены = Неопределено) Экспорт
	ФормаМетаданные = ОтчетМетаданные.ОсновнаяФормаНастроек;
	Если ФормаМетаданные = Неопределено Тогда
		Если ПоУмолчаниюВсеПодключены = Неопределено Тогда
			ПоУмолчаниюВсеПодключены = ПоУмолчаниюВсеПодключеныКФормеНастроек();
		КонецЕсли;
		ОтчетПодключен = ПоУмолчаниюВсеПодключены;
	Иначе
		ОтчетПодключен = (ФормаМетаданные = Метаданные.ОбщиеФормы.ФормаНастроекОтчета);
	КонецЕсли;
	Возврат ОтчетПодключен;
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОтчетПодключенКОсновнойФорме (БСП)

ПодключитьСхему (БСП)

ПредставлениеЭлементаУсловногоОформления (БСП)

НастройкиФормыОтчета (БСП)

ОтчетПодключенКХранилищу (БСП)

ПодключитьВнешнююОбработку (БСП)

ПодключитьОтчетИЗагрузитьНастройки (БСП)

ПриОпределенииТипаИСсылкиЕслиОтчетДополнительный (БСП)

TurboConf - расширение Конфигуратора 1С