ОтчетПодключенКОсновнойФорме (БСП)

Автор: 1С
ОбщийМодуль.ВариантыОтчетов
БСП

Отчет подключен основной форме. Определяет подключен-ли отчет к общей форме отчета.

// Определяет подключен-ли отчет к общей форме отчета.
Функция ОтчетПодключенКОсновнойФорме(ОтчетМетаданные, ПоУмолчаниюВсеПодключены = Неопределено) Экспорт
	ФормаМетаданные = ОтчетМетаданные.ОсновнаяФорма;
	Если ФормаМетаданные = Неопределено Тогда
		Если ПоУмолчаниюВсеПодключены = Неопределено Тогда
			ПоУмолчаниюВсеПодключены = ПоУмолчаниюВсеПодключеныКОсновнойФорме();
		КонецЕсли;
		ОтчетПодключен = ПоУмолчаниюВсеПодключены;
	Иначе
		ОтчетПодключен = (ФормаМетаданные = Метаданные.ОбщиеФормы.ФормаОтчета);
	КонецЕсли;
	Возврат ОтчетПодключен;
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОтчетПодключенКФормеНастроек (БСП)

ОтчетПодключенКХранилищу (БСП)

Отобразить заголовки периодов на форме отчета БСП

ПодключитьВнешнююОбработку (БСП)

ПодключитьОтчетИЗагрузитьНастройки (БСП)

Переопределение основных настроек динамического списка БСП

ПриОпределенииТипаИСсылкиЕслиОтчетДополнительный (БСП)

Подключены (БСП)

TurboConf ИР адаптер 1.44