ОтчетПодключенКХранилищу (БСП)

Автор: 1С
ОбщийМодуль.ВариантыОтчетов
БСП

Отчет подключен хранилищу. Определяет подключен-ли отчет к хранилищу вариантов отчетов.

// Определяет подключен-ли отчет к хранилищу вариантов отчетов.
Функция ОтчетПодключенКХранилищу(ОтчетМетаданные, ПоУмолчаниюВсеПодключены = Неопределено) Экспорт
	ХранилищеМетаданные = ОтчетМетаданные.ХранилищеВариантов;
	Если ХранилищеМетаданные = Неопределено Тогда
		Если ПоУмолчаниюВсеПодключены = Неопределено Тогда
			ПоУмолчаниюВсеПодключены = ПоУмолчаниюВсеПодключеныКХранилищу();
		КонецЕсли;
		ОтчетПодключен = ПоУмолчаниюВсеПодключены;
	Иначе
		ОтчетПодключен = (ХранилищеМетаданные = Метаданные.ХранилищаНастроек.ХранилищеВариантовОтчетов);
	КонецЕсли;
	Возврат ОтчетПодключен;
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПриОпределенииТипаИСсылкиЕслиОтчетДополнительный (БСП)

ОтчетПодключенКОсновнойФорме (БСП)

ОтчетПодключенКФормеНастроек (БСП)

ПодключитьВнешнююОбработку (БСП)

ПодключитьОтчетИЗагрузитьНастройки (БСП)

ХранилищеВариантовДополнительногоОтчетаКорректное (БСП)

УдалитьПользовательскийВариантОтчета (БСП)

ПриУдаленииПользовательскихВариантовОтчета (БСП)

TurboConf - расширение Конфигуратора 1С