ПараметрыОбновленияНастроек (БСП)

Автор: 1С
ОбщийМодуль.ВариантыОтчетов
БСП

Параметры обновления настроек. Прочие процедуры служебного программного интерфейса.

////////////////////////////////////////////////////////////////////////////////
// Прочие процедуры служебного программного интерфейса.

Функция ПараметрыОбновленияНастроек() Экспорт
	
	Настройки = Новый Структура;
	Настройки.Вставить("Конфигурация",      Истина);
	Настройки.Вставить("Расширения",        Ложь);
	Настройки.Вставить("ОбщиеДанные",       Истина);
	Настройки.Вставить("РазделенныеДанные", Истина);
	Настройки.Вставить("Оперативное",       Истина);
	Настройки.Вставить("Отложенное",        Ложь);
	Настройки.Вставить("ИндексироватьСхему",Ложь); // 
	Если ОбщегоНазначения.РазделениеВключено() Тогда
		Если ОбщегоНазначения.ДоступноИспользованиеРазделенныхДанных() Тогда
			Настройки.ОбщиеДанные       = Ложь;
		Иначе // Неразделенный сеанс.
			Настройки.РазделенныеДанные = Ложь;
		КонецЕсли;
	ИначеЕсли ОбщегоНазначения.ЭтоАвтономноеРабочееМесто() Тогда // АРМ.
		Настройки.ОбщиеДанные       = Ложь;
	КонецЕсли;

	Настройки.Расширения = Настройки.РазделенныеДанные;
	Возврат Настройки;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПараметрыОбновленияФайла (БСП)

ПолучитьПараметрыФормыНастроек (БСП)

Параметры (БСП)

ЗаписатьСтатусОбновления (БСП)

ПараметрыОбновления (БСП)

НовыеПараметрыОбработчикаОбновления (БСП)

СлужебнаяПараметрыПолученияОбновлений (БСП)

ПараметрыОповещенияОДоступномОбновлении (БСП)

TurboConf - расширение Конфигуратора 1С