ПредставленияЗаполнены (БСП)

Автор: 1С
ОбщийМодуль.ВариантыОтчетов
БСП

Представления заполнены.

Функция ПредставленияЗаполнены(Знач Режим = "") Экспорт
	
	ИмяПараметра = ВариантыОтчетовКлиентСервер.ПолноеИмяПодсистемы() + ".ПредставленияЗаполнены";
	Если Режим = "ОбщиеДанныеКонфигурации" Тогда
		Параметры = СтандартныеПодсистемыСервер.ПараметрРаботыПрограммы(ИмяПараметра);
	ИначеЕсли Режим = "РазделенныеДанныеКонфигурации" Тогда
		Параметры = СтандартныеПодсистемыСервер.ПараметрРаботыРасширения(ИмяПараметра);
	Иначе
		РезультатОбщий = ПредставленияЗаполнены("ОбщиеДанныеКонфигурации");
		РезультатРазделенный = ПредставленияЗаполнены("РазделенныеДанныеКонфигурации");
		Если РезультатОбщий = "НеЗаполнены" Или РезультатРазделенный = "НеЗаполнены" Тогда
			Возврат "НеЗаполнены";
		ИначеЕсли РезультатОбщий = "Заполняются" Или РезультатРазделенный = "Заполняются" Тогда
			Возврат "Заполняются";
		КонецЕсли;
		Возврат "Заполнены";
	КонецЕсли;
	Если Параметры = Неопределено Тогда
		Параметры = Новый Соответствие;
	КонецЕсли;
	
	Результат = Параметры[ТекущийЯзык().КодЯзыка];
	Если ТипЗнч(Результат) = Тип("Дата") Тогда
		Возврат ?(ТекущаяДатаСеанса() - Результат < 15 * 60, "Заполняются", "НеЗаполнены"); // таймаут - 15 минут
	КонецЕсли;
	Возврат ?(Результат = Истина, "Заполнены", "НеЗаполнены");
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЗаполнитьВсеРазрешеныПредставление (БСП)

ЗаполнитьПредставленияПредопределенныхВариантовОтчетов (БСП)

ЗаполнитьРеквизитыПоСКД (БСП)

ПредставлениеСмТакже (БСП)

ПредставлениеВажный (БСП)

ПросклонятьПредставление (БСП)

ПредставлениеПисьма (БСП)

ПредставлениеРасписания (БСП)

ПредставлениеРоли (БСП)

TurboConf ИР адаптер 1.37