СохранитьОбщиеНастройкиПанели (БСП)

Автор: 1С
ОбщийМодуль.ВариантыОтчетов
БСП

Сохранить общие настройки панели. Глобальные настройки панели отчетов.

// Глобальные настройки панели отчетов.
Функция СохранитьОбщиеНастройкиПанели(ОбщиеНастройки) Экспорт
	Если ТипЗнч(ОбщиеНастройки) <> Тип("Структура") Тогда
		Возврат Неопределено;
	КонецЕсли;
	Если ОбщиеНастройки.Количество() < 3 Тогда
		ОбщегоНазначенияКлиентСервер.ДополнитьСтруктуру(ОбщиеНастройки, ОбщиеНастройкиПанели(), Ложь);
	КонецЕсли;
	ОбщегоНазначения.ХранилищеОбщихНастроекСохранить(
		ВариантыОтчетовКлиентСервер.ПолноеИмяПодсистемы(),
		"ПанельОтчетов",
		ОбщиеНастройки);
	Возврат ОбщиеНастройки;
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОбщиеНастройкиПанели (БСП)

ХранилищеОбщихНастроекСохранить (БСП)

ПоказатьПанельОтчетов (БСП)

СохранитьНастройкиОбновленияКонфигурации (БСП)

НастроитьВариантыОтчетов (БСП)

ХранилищеОбщихНастроекСохранитьМассив (БСП)

TurboConf - расширение Конфигуратора 1С