ХранилищеВариантовДополнительногоОтчетаКорректное (БСП)

Автор: 1С
ОбщийМодуль.ВариантыОтчетов
БСП

Хранилище вариантов дополнительного отчета корректное. Проверяет значение свойства отчета Хранилище вариантов.

// Проверяет значение свойства отчета Хранилище вариантов.
//
// Параметры:
//   МетаданныеОтчета - ОбъектМетаданных - Метаданные отчета, свойство которого проверяется.
//   ТекстПредупреждения - Строка - Описание результата проверки.
//
// Возвращаемое значение: 
//   Булево -
//       * Истина - Значение свойства отчета Хранилище вариантов равно ХранилищеВариантовОтчетов;
//       * Ложь - Значение свойства не установлено или установлено, но ссылается
//                на Хранилище вариантов, не предусмотренное подсистемой.
//
Функция ХранилищеВариантовДополнительногоОтчетаКорректное(МетаданныеОтчета, ТекстПредупреждения = "") Экспорт 
	Если МетаданныеОтчета.ХранилищеВариантов = Метаданные.ХранилищаНастроек.ХранилищеВариантовОтчетов Тогда 
		Возврат Истина;
	КонецЕсли;
	
	ШаблонПредупреждения = НСтр("ru = 'Свойство отчета ""Хранилище вариантов"" %1.
		|Сохранение (выбор) вариантов отчета будет работать в ограниченном режиме.
		|Обратитесь к разработчику дополнительного (внешнего) отчета.'");
	
	ПараметрПредупреждения = НСтр("ru = 'заполнено не корректно'");
	Если МетаданныеОтчета.ХранилищеВариантов = Неопределено Тогда 
		ПараметрПредупреждения = НСтр("ru = 'не заполнено'");
	КонецЕсли;
	
	ТекстПредупреждения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
		ШаблонПредупреждения, ПараметрПредупреждения);
	
	ОбщегоНазначения.СообщитьПользователю(ТекстПредупреждения);
	
	Возврат Ложь;
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПриОпределенииТипаИСсылкиЕслиОтчетДополнительный (БСП)

УдалитьПользовательскийВариантОтчета (БСП)

ПриУдаленииПользовательскихВариантовОтчета (БСП)

ПриЗаписиДополнительногоОтчета (БСП)

ОткрытьВариантДополнительногоОтчета (БСП)

ОтчетПодключенКХранилищу (БСП)

КлючиВариантовОтчета (БСП)

ПриПодключенииОтчета (БСП)

Дополнительная расшифровка отчета БСП

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз