ЗаполнитьПредставленияПредопределенныхВариантовОтчетов (БСП)

Автор: 1С
ОбщийМодуль.ВариантыОтчетов
БСП

Заполнить представления предопределенных вариантов отчетов. Обработчик регламентного задания ЗаполнениеПредставленийПредопределенныхВариантовОтчетов.

// Обработчик регламентного задания ЗаполнениеПредставленийПредопределенныхВариантовОтчетов.
Процедура ЗаполнитьПредставленияПредопределенныхВариантовОтчетов(Языки, ИндексТекущегоЯзыка) Экспорт
	
	ОбщегоНазначения.ПриНачалеВыполненияРегламентногоЗадания(
		Метаданные.РегламентныеЗадания.ОбновлениеПредопределенныхВариантовОтчетов);
	
	УстановитьОтключениеБезопасногоРежима(Истина);
	УстановитьПривилегированныйРежим(Истина);
	
	ПараметрыОбновления = ПараметрыОбновленияНастроек();
	ПараметрыОбновления.Отложенное = Истина;
	Обновить(ПараметрыОбновления);
	
	Если ИндексТекущегоЯзыка < Языки.Количество() - 1 Тогда
		ЗапланироватьЗаполнениеПредставлений(Языки, ИндексТекущегоЯзыка + 1);
		Возврат;
	КонецЕсли;
	
	Задания = РегламентныеЗадания.ПолучитьРегламентныеЗадания(
		Новый Структура("Метаданные", Метаданные.РегламентныеЗадания.ОбновлениеПредопределенныхВариантовОтчетов));
	Для каждого ЗаполнениеПредставлений Из Задания Цикл
		ЗаполнениеПредставлений.Удалить();
	КонецЦикла;		

КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПредопределенныеВариантыОтчетов (БСП)

ПользовательскиеВариантыОтчетов (БСП)

СброситьНастройкиВариантаОтчета (БСП)

ПриПолученииПользовательскихВариантовОтчетов (БСП)

ОбновитьИндексПоискаПредопределенныхВариантовОтчетов (БСП)

ПредставленияЗаполнены (БСП)

УдалитьВариантОтчета (БСП)

УдалитьПользовательскийВариантОтчета (БСП)

ПриУдаленииПользовательскихВариантовОтчета (БСП)

TurboConf - расширение Конфигуратора 1С