ДеревоПодсистемИспользованиеПриИзменении (БСП)

Автор: 1С
ОбщийМодуль.ВариантыОтчетовКлиент
БСП

Дерево подсистем использование при изменении. Процедура обслуживает событие реквизита ДеревоПодсистем в формах редактирования.

// Процедура обслуживает событие реквизита ДеревоПодсистем в формах редактирования.
Процедура ДеревоПодсистемИспользованиеПриИзменении(Форма, Элемент) Экспорт
	СтрокаДерева = Форма.Элементы.ДеревоПодсистем.ТекущиеДанные;
	Если СтрокаДерева = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	// Пропуск корневой строки
	Если СтрокаДерева.Приоритет = "" Тогда
		СтрокаДерева.Использование = 0;
		Возврат;
	КонецЕсли;
	
	Если СтрокаДерева.Использование = 2 Тогда
		СтрокаДерева.Использование = 0;
	КонецЕсли;
	
	СтрокаДерева.Модифицированность = Истина;
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ДеревоПодсистемВажностьПриИзменении (БСП)

ДеревоПодсистемЗаписать (БСП)

УстановитьУсловноеОформлениеДереваПодсистем (БСП)

ДеревоПодсистемСформировать (БСП)

ПриОтправкеВерсийПодсистем (БСП)

ПодсистемыТекущегоПользователя (БСП)

ИнтерактивноеИзменениеВыгрузки_СформироватьДеревоЗначений (БСП)

ИспользованиеСобытияДоступ (БСП)

ПриПолученииРазделовПолнотекстовогоПоиска (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз