ДобавитьКомментарийКВерсии (БСП)

Автор: 1С
ОбщийМодуль.ВерсионированиеОбъектов
БСП

Добавить комментарий версии. Только для служебного использования.

// Только для служебного использования.
// Комментарий записывается, если пользователь является либо автором версии, либо администратором.
Процедура ДобавитьКомментарийКВерсии(СсылкаНаОбъект, НомерВерсии, Комментарий) Экспорт
	
	Если Не ЕстьПравоЧтенияДанныхВерсийОбъектов() Тогда
		Возврат;
	КонецЕсли;
	
	УстановитьПривилегированныйРежим(Истина);
	
	МенеджерЗаписи = РегистрыСведений.ВерсииОбъектов.СоздатьМенеджерЗаписи();
	МенеджерЗаписи.Объект = СсылкаНаОбъект;
	МенеджерЗаписи.НомерВерсии = НомерВерсии;
	МенеджерЗаписи.Прочитать();
	Если МенеджерЗаписи.Выбран() Тогда
		Если МенеджерЗаписи.АвторВерсии = Пользователи.ТекущийПользователь() Или Пользователи.ЭтоПолноправныйПользователь(, , Ложь) Тогда
			МенеджерЗаписи.Комментарий = Комментарий;
			МенеджерЗаписи.Записать();
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ДобавитьИзмененияПараметраРаботыПрограммы (БСП)

КомментарийЗавершениеВвода (БСП)

ДобавитьПереименование (БСП)

ДобавитьПодписьКФайлу (БСП)

СформироватьЗаголовокКомментариев (БСП)

СформироватьПредзаголовокКомментария (БСП)

КартинкаКомментария (БСП)

УстановитьКомментарийЗамера (БСП)

TurboConf - расширение Конфигуратора 1С