КонтрольнаяСумма (БСП)

Автор: 1С
ОбщийМодуль.ВерсионированиеОбъектов
БСП

Контрольная сумма. Контрольная сумма по алгоритму MD5.

// Контрольная сумма по алгоритму MD5.
Функция КонтрольнаяСумма(Данные) Экспорт
	ХешированиеДанных = Новый ХешированиеДанных(ХешФункция.MD5);
	
	Если ТипЗнч(Данные) = Тип("Структура") Тогда
		ХешированиеДанных.Добавить(Данные.Объект);
		Если Данные.Свойство("ДополнительныеРеквизиты") Тогда
			ХешированиеДанных.Добавить(ОбщегоНазначения.ЗначениеВСтрокуXML(Данные.ДополнительныеРеквизиты));
		КонецЕсли;
	Иначе
		ХешированиеДанных.Добавить(Данные);
	КонецЕсли;
	
	Возврат СтрЗаменить(ХешированиеДанных.ХешСумма, " ", "");
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

КонтрольнаяСуммаПроблемы (БСП)

КонтрольнаяСуммаСтрокой (БСП)

КонтрольныеСуммыФайловКомплектаВнешнейКомпоненты (БСП)

КонтрольнаяСуммаФайла (БСП)

СократитьСтрокуКонтрольнойСуммой (БСП)

КонтрольныйКлючЛицевогоСчетаСоответствуетТребованиям (БСП)

Загадка суммы и произведения

Пересчет сумм в табличной части документа

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз