ПриПереходеНаВерсиюОбъекта (БСП)

Автор: 1С
ОбщийМодуль.ВерсионированиеОбъектов
БСП

При переходе на версию объекта. Обработчик перехода на версию объекта.

// Обработчик перехода на версию объекта.
//
// Параметры:
//	ОбъектСсылка - Ссылка - Ссылка на объект, для которого имеется версия.
//	НомерВерсииДляПерехода - Число - Номер версии, на которую необходимо выполнить переход.
//	НомерИгнорируемойВерсии - Число - Номер версии, на которую необходимо проигнорировать.
//	ПропуститьПроверкуЗапретаИзменения - Булево - Признак пропуска проверки даты запрета загрузки.
//
Процедура ПриПереходеНаВерсиюОбъекта(СсылкаНаОбъект, Знач НомерВерсии) Экспорт
	
	ПроверитьНаличиеПравНаИзменениеОбъекта(СсылкаНаОбъект.Метаданные());
	
	УстановитьПривилегированныйРежим(Истина);
	
	НаборЗаписей = ЗаписьОВерсииОбъекта(СсылкаНаОбъект, НомерВерсии);
	Запись = НаборЗаписей[0];
	
	Если Запись.ТипВерсииОбъекта = Перечисления.ТипыВерсийОбъекта.ПринятыеДанныеПоКоллизии Тогда
		
		НомерВерсии = НомерВерсии - 1;
		
		Если НомерВерсии <> 0 Тогда
			
			ПредыдущаяЗапись = ЗаписьОВерсииОбъекта(СсылкаНаОбъект, НомерВерсии)[0];
			НомерВерсии = ПредыдущаяЗапись.НомерВерсии;
			
		КонецЕсли;
		
	Иначе
		НомерВерсии = Запись.НомерВерсии;
	КонецЕсли;
	
	ТекстСообщенияОбОшибке = "";
	ПерейтиНаВерсиюСервер(СсылкаНаОбъект, НомерВерсии, ТекстСообщенияОбОшибке);
	
	Если Не ПустаяСтрока(ТекстСообщенияОбОшибке) Тогда
		ВызватьИсключение ТекстСообщенияОбОшибке;
	КонецЕсли;
	
	Запись.ВерсияПроигнорирована = Истина;
	НаборЗаписей.Записать();
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ДобавитьПереименование (БСП)

ЗаполнитьНаименованиеПредопределенногоЭлементаВсеОбъектыАдресации (БСП)

переход с 1с 7.7 на 8 версию

ЗарегистрироватьУчетныеЗаписиЭлектроннойПочтыКОбработкеДляПереходаНаНовуюВерсию (БСП)

ПриПроверкеВерсииПлатформыПриЗапуске (БСП)

ОбновитьПредопределенныеВидыКонтактнойИнформацииПользователей (БСП)

ДобавитьАдминистраторамПравоОткрытияВнешнихОтчетовИОбработок (БСП)

ЗаполнитьНаименованиеПредопределенныхГруппПользователей (БСП)

ПриОпределенииНаследованияПодсистем (БСП)

TurboConf - расширение Конфигуратора 1С