СоздатьВерсиюОбъектаПоОбменуДанными (БСП)

Автор: 1С
ОбщийМодуль.ВерсионированиеОбъектов
БСП

Создать версию объекта по обмену данными. Записывает в информационную базу версию объекта, полученного при обмене данными.

// Записывает в информационную базу версию объекта, полученного при обмене данными.
//
// Параметры:
//  Объект - Объект - записываемый объект.
//  СведенияОВерсииОбъекта - Структура - содержит информацию о версии объекта.
//  СсылкаСуществует - Булево - признак наличия объекта по ссылке в информационной базе.
Процедура СоздатьВерсиюОбъектаПоОбменуДанными(Объект, СведенияОВерсииОбъекта, СсылкаСуществует, Отправитель) Экспорт
	
	Ссылка = Объект.Ссылка;
	
	Если Не ЗначениеЗаполнено(СсылкаСуществует) Тогда
		СсылкаСуществует = ОбщегоНазначения.СсылкаСуществует(Ссылка);
	КонецЕсли;
	
	ТипВерсииОбъекта = Перечисления.ТипыВерсийОбъекта[СведенияОВерсииОбъекта.ТипВерсииОбъекта];
	
	НомерПоследнейВерсии = 0;
	Если СсылкаСуществует Тогда
		Если ОбъектВерсионируется(Ссылка, НомерПоследнейВерсии) И РегистрВерсийВходитВСоставПланаОбмена(Отправитель) Тогда
			Возврат;
		КонецЕсли;
	Иначе
		Ссылка = ОбщегоНазначения.МенеджерОбъектаПоСсылке(Ссылка).ПолучитьСсылку(Объект.ПолучитьСсылкуНового().УникальныйИдентификатор());
	КонецЕсли;
	
	СведенияОВерсииОбъекта.Вставить("Объект", Ссылка);
	СведенияОВерсииОбъекта.Вставить("НомерВерсии", Число(НомерПоследнейВерсии) + 1);
	СведенияОВерсииОбъекта.ТипВерсииОбъекта = ТипВерсииОбъекта;
	
	Если Не ЗначениеЗаполнено(СведенияОВерсииОбъекта.АвторВерсии) Тогда
		СведенияОВерсииОбъекта.АвторВерсии = Пользователи.АвторизованныйПользователь();
	КонецЕсли;
	
	СоздатьВерсиюОбъекта(Объект, СведенияОВерсииОбъекта, Ложь);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЕстьПравоЧтенияДанныхВерсийОбъектов (БСП)

ОписаниеДанныхФайлаКлассификатора (БСП)

ДанныеРазличаются (БСП)

СоздатьВерсию (БСП)

СоздатьФайлСВерсией (БСП)

ОтчетПоВерсииОбъекта (БСП)

СохранитьИзмененияИОсвободитьФайлПоСсылке (БСП)

СкопироватьСтруктуру (БСП)

СостоянияОбменовДанными (БСП)

TurboConf - расширение Конфигуратора 1С