ЗаписатьНастройкуВерсионированияПоОбъекту (БСП)

Автор: 1С
ОбщийМодуль.ВерсионированиеОбъектов
БСП

Записать настройку версионирования по объекту. Записывает настройку версионирования объекта.

// Записывает настройку версионирования объекта.
//
// Параметры:
//  ТипОбъекта - Строка, Тип, ОбъектМетаданных, СправочникСсылка.ИдентификаторыОбъектовМетаданных - объект метаданных;
//  ВариантВерсионирования - ПеречислениеСсылка.ВариантыВерсионированияОбъектов - условие записи версий;
//  СрокХраненияВерсий - ПеречислениеСсылка.СрокиХраненияВерсий - срок, после которого версии подлежат очистке.
//
Процедура ЗаписатьНастройкуВерсионированияПоОбъекту(Знач ТипОбъекта, Знач ВариантВерсионирования, Знач СрокХраненияВерсий = Неопределено) Экспорт
	
	Если ТипЗнч(ТипОбъекта) <> Тип("СправочникСсылка.ИдентификаторыОбъектовМетаданных") Тогда
		ТипОбъекта = ОбщегоНазначения.ИдентификаторОбъектаМетаданных(ТипОбъекта);
	КонецЕсли;
	
	Настройка = РегистрыСведений.НастройкиВерсионированияОбъектов.СоздатьМенеджерЗаписи();
	Настройка.ТипОбъекта = ТипОбъекта;
	
	Если СрокХраненияВерсий = Неопределено Тогда
		Настройка.Прочитать();
		Если Настройка.Выбран() Тогда
			СрокХраненияВерсий = Настройка.СрокХраненияВерсий;
		Иначе
			Настройка.ТипОбъекта = ТипОбъекта;
			СрокХраненияВерсий = Перечисления.СрокиХраненияВерсий.Бессрочно;
		КонецЕсли;
	КонецЕсли;
	
	Настройка.СрокХраненияВерсий = СрокХраненияВерсий;
	Настройка.Вариант = ВариантВерсионирования;
	Настройка.Записать();
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОбновитьНастройкиВерсионированияОбъектов (БСП)

ПоказатьНастройку (БСП)

ВключеноВерсионированиеОбъекта (БСП)

ВключеноВерсионированиеОбъектов (БСП)

ЗаписатьНастройкиОбновления (БСП)

ВключитьВерсионированиеОбъекта (БСП)

ВключитьВерсионированиеОбъектов (БСП)

ЗаписатьНастройкиАвтоматическогоОбновления (БСП)

ЗначениеФлажкаХранитьИсторию (БСП)

TurboConf - расширение Конфигуратора 1С