ЗаписатьВерсиюОбъекта (БСП)

Автор: 1С
ОбщийМодуль.ВерсионированиеОбъектов
БСП

Записать версию объекта. Записывает версию объекта в информационную базу.

// Записывает версию объекта в информационную базу.
//
// Параметры:
//  Источник - СправочникОбъект, ДокументОбъект и т.п. - записываемый объект ИБ;
//  РежимЗаписи - РежимЗаписиДокумента.
//
Процедура ЗаписатьВерсиюОбъекта(Знач Источник, РежимЗаписи = Неопределено) Экспорт
	
	// Безусловная проверка на ОбменДанными.Загрузка не требуется, т.к. в момент записи
	// версионируемого объекта при обмене необходимо сохранить его текущую версию в истории версий.
	Если Не ПолучитьФункциональнуюОпцию("ИспользоватьВерсионированиеОбъектов") Тогда
		Возврат;
	КонецЕсли;
	
	Если ОбщегоНазначения.ЗначениеСсылочногоТипа(Источник) Тогда
		Источник = Источник.ПолучитьОбъект();
	КонецЕсли;
	
	Если Источник = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	Если Источник.ОбменДанными.Загрузка
		И Источник.ДополнительныеСвойства.Свойство("ПропуститьЗаписьВерсииОбъекта")
		И ПривилегированныйРежим() Тогда
		Возврат;
	КонецЕсли;
	
	Если СтандартныеПодсистемыСервер.ЭтоИдентификаторОбъектаМетаданных(Источник) Тогда
		Возврат;
	КонецЕсли;
	
	Если Источник.ОбменДанными.Загрузка Тогда
		Если Не Источник.Ссылка.Пустая() Тогда
			ЗаписатьДанныеТекущейВерсии(Источник.Ссылка, Истина);
		КонецЕсли;
		Возврат;
	КонецЕсли;
	
	Если ВыполняетсяЗаписьОбъекта() Тогда
		Возврат;
	КонецЕсли;
	
	Если Источник.ДополнительныеСвойства.Свойство("СведенияОВерсииОбъекта") Тогда
		Возврат;
	КонецЕсли;
	
	ПриСозданииВерсииОбъекта(Источник, РежимЗаписи);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

НомерПоследнейВерсии (БСП)

ЗаписатьВерсиюДокумента (БСП)

ЗаписатьКодировкуВерсииФайла (БСП)

ЗаписатьКодировкуВерсииФайлаИИзвлеченныйТекст (БСП)

ЗаписатьНастройкуВерсионированияПоОбъекту (БСП)

ЗаписатьОбъектВФайл (БСП)

ЗаписатьОбъектВПоток (БСП)

ЗаписатьОбъектВИБ (БСП)

TurboConf - расширение Конфигуратора 1С