ПодключитьКомпонентуПослеПроверкиДоступности (БСП)

Автор: 1С
ОбщийМодуль.ВнешниеКомпонентыСлужебныйКлиент
БСП

Подключить компоненту после проверки доступности.

Процедура ПодключитьКомпонентуПослеПроверкиДоступности(Результат, Контекст) Экспорт
	
	Если Результат.Доступна Тогда 
		ОбщегоНазначенияСлужебныйКлиент.ПодключитьКомпоненту(Контекст);
	Иначе
		Если Не ПустаяСтрока(Результат.ОписаниеОшибки) Тогда 
			ТекстОшибки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
				НСтр("ru = 'Не удалось подключить внешнюю компоненту ""%1"" на клиенте
				           |из хранилища внешних компонент
				           |по причине:
				           |%2'"),
				Контекст.Идентификатор,
				Результат.ОписаниеОшибки);
		КонецЕсли;
		
		ОбщегоНазначенияСлужебныйКлиент.ПодключитьКомпонентуОповеститьОбОшибке(ТекстОшибки, Контекст);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УстановитьКомпонентуПослеПроверкиДоступности (БСП)

ПроверитьДоступностьКомпонентыПослеПоискаКомпонентыНаПортале (БСП)

ПодключитьКомпонентуПослеПопыткиПодключения (БСП)

ПодключитьКомпонентуПослеУстановки (БСП)

ПроверитьДоступностьКомпонентыПослеОтображенияДоступныхВидовКлиентов (БСП)

ПодключитьКомпоненту (БСП)

ПодключитьКомпонентуИзРеестраWindowsПослеПопыткиПодключения (БСП)

ПодключитьКомпонентуЗавершение (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз