НастроитьОтображениеСпискаВнешнихПользователей (БСП)

Автор: 1С
ОбщийМодуль.ВнешниеПользователи
БСП

Настроить отображение списка внешних пользователей. Используется для настройки отображения наличия внешних пользователей в списках справочников (партнеры, респонденты и др.),

// Используется для настройки отображения наличия внешних пользователей в списках справочников (партнеры, респонденты и др.), 
// являющихся объектом авторизации в справочнике ВнешниеПользователи.
//
// Параметры:
//  Форма - ФормаКлиентскогоПриложения - вызывающий объект.
//
Процедура НастроитьОтображениеСпискаВнешнихПользователей(Форма) Экспорт
	
	Если ПравоДоступа("Чтение", Метаданные.Справочники.ВнешниеПользователи) Тогда
		Возврат;
	КонецЕсли;
	
	// Удаление отображения недоступных сведений.
	СхемаЗапроса = Новый СхемаЗапроса;
	СхемаЗапроса.УстановитьТекстЗапроса(Форма.Список.ТекстЗапроса);
	Источники = СхемаЗапроса.ПакетЗапросов[0].Операторы[0].Источники;
	Для Индекс = 0 По Источники.Количество() - 1 Цикл
		Если Источники[Индекс].Источник.ИмяТаблицы = "Справочник.ВнешниеПользователи" Тогда
			Источники.Удалить(Индекс);
		КонецЕсли;
	КонецЦикла;
	Форма.Список.ТекстЗапроса = СхемаЗапроса.ПолучитьТекстЗапроса();
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПриОпределенииПараметровКолонкиИндикации (БСП)

НастроитьОтборыДинамическогоСписка (БСП)

ЕстьПраво (БСП)

ОбработатьНеобходимостьОтображенияГруппПользователей (БСП)

ПриОпределенииДоступныхВнешнихСистем (БСП)

УстановитьФлагОтображенияОписанийДляНовогоПользователя (БСП)

ПриОпределенииПсевдонимаПользователя (БСП)

ПолноеИмяСлужебногоПользователя (БСП)

ТекущийВнешнийПользователь (БСП)

TurboConf - расширение Конфигуратора 1С