ПрочитатьОбъектИзПотока (БСП)

Автор: 1С
ОбщийМодуль.ВыгрузкаЗагрузкаДанныхСлужебный
БСП

Прочитать объект из потока. Возвращает объект из файла.

// Возвращает объект из файла.
//
// Параметры:
//	ПотокЧтения - ЧтениеXML - поток чтения.
//
// Возвращаемое значение:
//	Объект.
//
Функция ПрочитатьОбъектИзПотока(ПотокЧтения) Экспорт
	
	Если ПотокЧтения.ТипУзла <> ТипУзлаXML.НачалоЭлемента
			Или ПотокЧтения.Имя <> ИмяЭлементаСодержащегоОбъект() Тогда
		
		ВызватьИсключение СтрШаблон(НСтр("ru = 'Ошибка чтения XML. Неверный формат файла. Ожидается начало элемента %1.'"),
			ИмяЭлементаСодержащегоОбъект()
		);
		
	КонецЕсли;
	
	Если НЕ ПотокЧтения.Прочитать() Тогда
		ВызватьИсключение НСтр("ru = 'Ошибка чтения XML. Обнаружено завершение файла.'");
	КонецЕсли;
	
	Объект = СериализаторXDTO.ПрочитатьXML(ПотокЧтения);
	
	Возврат Объект;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЗаписатьОбъектВПоток (БСП)

ПрочитатьОбъектИзФайла (БСП)

ПрочитатьПолученныеДанныеОбъекта (БСП)

ПрочитатьОбъектXDTOИзФайла (БСП)

Значения реквизитов, прочитанных из информационной базы для нескольких объектов

ПослеРазбораВерсииОбъекта (БСП)

ЗначениеРеквизитаОбъекта (БСП)

ЗначенияРеквизитовОбъектов (БСП)

ЗначениеРеквизитаОбъектов (БСП)

TurboConf - расширение Конфигуратора 1С