XMLТипСсылки (БСП)

Автор: 1С
ОбщийМодуль.ВыгрузкаЗагрузкаДанныхСлужебный
БСП

Xml тип ссылки. Возвращает имя типа, который будет использован в xml файле для указанного объекта метаданных

// Возвращает имя типа, который будет использован в xml файле для указанного объекта метаданных
// Используется при поиске и замене ссылок при загрузке, при модификации схемы current-config при записи.
// 
// Параметры:
//  Значение - Объект метаданных или Ссылка.
//
// Возвращаемое значение:
//  Строка - Строка вида AccountingRegisterRecordSet.Хозрасчетный, описывающая объект метаданных.
//
Функция XMLТипСсылки(Знач Значение) Экспорт
	
	Если ТипЗнч(Значение) = Тип("ОбъектМетаданных") Тогда
		ОбъектМетаданных = Значение;
		МенеджерОбъекта = ИнтеграцияПодсистемБТС.МенеджерОбъектаПоПолномуИмени(ОбъектМетаданных.ПолноеИмя());
		Ссылка = МенеджерОбъекта.ПолучитьСсылку();
	Иначе
		ОбъектМетаданных = Значение.Метаданные();
		Ссылка = Значение;
	КонецЕсли;
	
	Если ОбщегоНазначенияБТС.ЭтоСсылочныеДанные(ОбъектМетаданных) Тогда
		
		Возврат СериализаторXDTO.XMLТипЗнч(Ссылка).ИмяТипа;
		
	Иначе
		
		ВызватьИсключение СтрШаблон(НСтр("ru = 'Ошибка при определении XMLТипа ссылки для объекта %1: объект не является ссылочным!'"),
			ОбъектМетаданных.ПолноеИмя());
		
	КонецЕсли;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОписаниеТипаВсеСсылки (БСП)

Получить ссылку по типу и гуид

ПустаяСсылка (БСП)

ОбъектМетаданныхПоТипуСсылки (БСП)

ПустыеСсылкиТиповОбъектовАвторизации (БСП)

ЭтоСсылка (БСП)

ПустыеСсылкиТиповЗначенийДоступаПоТипамГруппИЗначений (БСП)

ОпределитьСсылкуТипаИнформации (БСП)

ПустаяСсылкаОбъектаМетаданных (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз