ПередЗагрузкойНастроек (БСП)

Автор: 1С
ОбщийМодуль.ВыгрузкаЗагрузкаДанныхХранилищЗначений
БСП

Перед загрузкой настроек.

Процедура ПередЗагрузкойНастроек(Контейнер, ИмяХранилищаНастроек, КлючНастроек, КлючОбъекта, Настройки, Пользователь, Представление, Артефакты, Отказ) Экспорт
	
	Для Каждого Артефакт Из Артефакты Цикл
		
		Если Артефакт.Тип() = ТипАртефактХранилищаЗначений() И Артефакт.Owner.Тип() = ТипВладелецТело() Тогда
			
			ЗагрузитьХранилищеЗначения(Контейнер, Настройки, Артефакт);
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПередЗагрузкойНастроекВКомпоновщик (БСП)

ПередЗагрузкойДанныхИзНастроекНаСервереТекущиеДела (БСП)

ПередЗагрузкойДанныхИзНастроекНаСервере (БСП)

ПередВыгрузкойНастроек (БСП)

ПередЗагрузкойДанных (БСП)

ПередЗагрузкойОбъекта (БСП)

TurboConf - расширение Конфигуратора 1С