СписокОбъектовМетаданныхИмеющихХранилищеЗначения (БСП)

Автор: 1С
ОбщийМодуль.ВыгрузкаЗагрузкаДанныхХранилищЗначенийПовтИсп
БСП

Список объектов метаданных имеющих хранилище значения. Возвращает список объектов метаданных, имеющих свойства, для которых используется тип

// Возвращает список объектов метаданных, имеющих свойства, для которых используется тип
// ХранилищеЗначения.
//
// Возвращаемое значение:
//  ФиксированноеСоответствие:
//    * Ключ - Строка, полное имя объекта метаданных,
//    * Значение - Массив(Структура), поля структуры:
//       * ИмяРеквизита - Строка, имя свойства,
//       * ИмяТабличнойЧасти - Строка, имя табличной части (используется только для реквизитов табличных
//          частей объектов).
//
Функция СписокОбъектовМетаданныхИмеющихХранилищеЗначения() Экспорт
	
	СписокМетаданных = Новый Соответствие;
	
	Для Каждого МетаданныеОбъекта Из ВыгрузкаЗагрузкаДанныхСлужебный.ВсеКонстанты() Цикл
		ДобавитьКонстантуВСписокМетаданных(МетаданныеОбъекта, СписокМетаданных);
	КонецЦикла;
	
	Для Каждого МетаданныеОбъекта Из ВыгрузкаЗагрузкаДанныхСлужебный.ВсеСсылочныеДанные() Цикл
		ДобавитьСсылочныйТипВСписокМетаданных(МетаданныеОбъекта, СписокМетаданных);
	КонецЦикла;
	
	Для Каждого МетаданныеОбъекта Из ВыгрузкаЗагрузкаДанныхСлужебный.ВсеНаборыЗаписей() Цикл
		ДобавитьРегистрВТаблицуМетаданных(МетаданныеОбъекта, СписокМетаданных);
	КонецЦикла;
	
	Возврат Новый ФиксированноеСоответствие(СписокМетаданных);
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ИдентификаторыОбъектовМетаданныхФормаСпискаСписокВыборЗначения (БСП)

СписокСвойствДляВидаОбъектов (БСП)

ПодключенныеОбъектыМетаданных (БСП)

ИменаМетаданныхНеВыгружаемыхОбъектовУзла (БСП)

РазделенныеОбъектыМетаданных (БСП)

ИсточникиКомандПечати (БСП)

Возвращает полное имя объекта метаданных по переданному значению ссылки

Возвращает полное имя объекта метаданных по переданному значению ссылки

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз