ПередВыгрузкойНастроек (БСП)

Автор: 1С
ОбщийМодуль.ВыгрузкаЗагрузкаИзбранногоРаботыПользователей
БСП

Перед выгрузкой настроек.

Процедура ПередВыгрузкойНастроек(Контейнер, Сериализатор, ИмяХранилищаНастроек, КлючНастроек, КлючОбъекта, Настройки, Пользователь, Представление, Артефакты, Отказ) Экспорт
	
	Если ТипЗнч(Настройки) = Тип("ИзбранноеРаботыПользователя") Тогда
		
		Для Каждого ЭлементИзбранного Из Настройки Цикл
			
			НовыйАртефакт = ФабрикаXDTO.Создать(ТипАртефактЭлементИзбранного());
			НовыйАртефакт.Important = ЭлементИзбранного.Важное;
			НовыйАртефакт.URL = ОтображениеНавигационнойСсылкиВАртефакт(ЭлементИзбранного.НавигационнаяСсылка);
			НовыйАртефакт.Presentation = ЭлементИзбранного.Представление;
			
			Артефакты.Добавить(НовыйАртефакт);
			
		КонецЦикла;
		
		Настройки = Новый ИзбранноеРаботыПользователя();
		
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПередВыгрузкойНастроек (БСП)

ПередВыгрузкойДанных (БСП)

ПередВыгрузкойОбъекта (БСП)

ПередЗагрузкойНастроек (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз