ПередЗагрузкойНастроек (БСП)

Автор: 1С
ОбщийМодуль.ВыгрузкаЗагрузкаИзбранногоРаботыПользователей
БСП

Перед загрузкой настроек.

Процедура ПередЗагрузкойНастроек(Контейнер, ИмяХранилищаНастроек, КлючНастроек, КлючОбъекта, Настройки, Пользователь, Представление, Артефакты, Отказ) Экспорт
	
	Если ТипЗнч(Настройки) = Тип("ИзбранноеРаботыПользователя") Тогда
		
		Для Каждого Артефакт Из Артефакты Цикл
			
			Если Артефакт.Тип() = ТипАртефактЭлементИзбранного() Тогда
				
				НовыйЭлемент = Новый ЭлементИзбранногоРаботыПользователя();
				НовыйЭлемент.Важное = Артефакт.Important;
				НовыйЭлемент.НавигационнаяСсылка = НавигационнаяСсылкаПоОтображениюВАртефакт(Артефакт.URL);
				НовыйЭлемент.Представление = Артефакт.Presentation;
				
				Настройки.Добавить(НовыйЭлемент);
				
			КонецЕсли;
			
		КонецЦикла;
		
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПередЗагрузкойНастроек (БСП)

ПередЗагрузкойНастроекВКомпоновщик (БСП)

ПередЗагрузкойДанныхИзНастроекНаСервереТекущиеДела (БСП)

ПередЗагрузкойДанныхИзНастроекНаСервере (БСП)

ПередВыгрузкойНастроек (БСП)

ПередЗагрузкойДанных (БСП)

ПередЗагрузкойОбъекта (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз