КонтрольСсылокНаНеразделенныеДанныеВРазделенныхПриВыгрузке (БСП)

Автор: 1С
ОбщийМодуль.ВыгрузкаЗагрузкаНеразделенныхДанныхПовтИсп
БСП

Контроль ссылок на неразделенные данные разделенных при выгрузке. Возвращает правила контроля ссылок на неразделенные данные в разделенных при выгрузке.

// Возвращает правила контроля ссылок на неразделенные данные в разделенных при выгрузке.
//
// Возвращаемое значение:
//  ФиксированноеСоответствие:
//    * Ключ - Строка - полное имя объекта метаданных, для которого должен выполняться контроль
//       наличия ссылок на неразделенные данные в разделенных при выгрузке данных.
//    * Значение - Массив(Строка) - массив имен полей объекта, в которых должен выполняться
//       контроль наличия ссылок на неразделенные данные в разделенных при выгрузке данных.
//
Функция КонтрольСсылокНаНеразделенныеДанныеВРазделенныхПриВыгрузке() Экспорт
	
	Кэш = Новый Соответствие();
	
	ТипыОбщихДанных = ВыгрузкаЗагрузкаДанныхСлужебныйСобытия.ПолучитьТипыОбщихДанныхПоддерживающиеСопоставлениеСсылокПриЗагрузке();
	ОбъектыИсключаемыеИзВыгрузкиЗагрузки = ВыгрузкаЗагрузкаДанныхСлужебныйСобытия.ПолучитьТипыИсключаемыеИзВыгрузкиЗагрузки();
	ОбъектыНеТребующиеСопоставленияСсылок = ВыгрузкаЗагрузкаДанныхСлужебныйСобытия.ПолучитьТипыОбщихДанныхНеТребующихСопоставлениеСсылокПриЗагрузке();
	
	ЛокальныйКэшСоставовРазделителей = Новый Соответствие();
	
	Для Каждого ОбъектМетаданных Из ВыгрузкаЗагрузкаДанныхСлужебный.ВсеКонстанты() Цикл
		ЗаполнитьКэшКонтроляСсылокНаНеразделенныеДанныеПриВыгрузкеДляКонстант(
			Кэш, ОбъектМетаданных, ТипыОбщихДанных, ОбъектыИсключаемыеИзВыгрузкиЗагрузки, ОбъектыНеТребующиеСопоставленияСсылок,
				ЛокальныйКэшСоставовРазделителей);
	КонецЦикла;
	
	Для Каждого ОбъектМетаданных Из ВыгрузкаЗагрузкаДанныхСлужебный.ВсеСсылочныеДанные() Цикл
		ЗаполнитьКэшКонтроляСсылокНаНеразделенныеДанныеПриВыгрузкеДляОбъектов(
			Кэш, ОбъектМетаданных, ТипыОбщихДанных, ОбъектыИсключаемыеИзВыгрузкиЗагрузки, ОбъектыНеТребующиеСопоставленияСсылок,
				ЛокальныйКэшСоставовРазделителей);
	КонецЦикла;
	
	Для Каждого ОбъектМетаданных Из ВыгрузкаЗагрузкаДанныхСлужебный.ВсеНаборыЗаписей() Цикл
		ЗаполнитьКэшКонтроляСсылокНаНеразделенныеДанныеПриВыгрузкеДляНаборовЗаписей(
			Кэш, ОбъектМетаданных, ТипыОбщихДанных, ОбъектыИсключаемыеИзВыгрузкиЗагрузки, ОбъектыНеТребующиеСопоставленияСсылок,
				ЛокальныйКэшСоставовРазделителей);
	КонецЦикла;
	
	Возврат Новый ФиксированноеСоответствие(Кэш);
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

КонтрольИспользованияСсылокНаНеразделенныеДанныеВРазделенных (БСП)

ВыполнитьКонтрольЗаписиНеразделенныхДанных (БСП)

КонтрольНеразделенныхДанныхПриОбновлении (БСП)

ЗаполнитьОбработчикиРазделенныхДанных (БСП)

ПриЗаполненииТиповОбщихДанныхПоддерживающихСопоставлениеСсылокПриЗагрузке (БСП)

ПриЗаполненииТиповОбщихДанныхНеТребующихСопоставлениеСсылокПриЗагрузке (БСП)

КонтрольЗаполненияПолейЕстественногоКлючаДляНеразделенныхОбъектов (БСП)

TurboConf - расширение Конфигуратора 1С