ЗагрузитьТекущуюОбластьДанныхИзАрхива (БСП)

Автор: 1С
ОбщийМодуль.ВыгрузкаЗагрузкаОбластейДанных
БСП

Загрузить текущую область данных из архива. Загружает данные приложения из zip архива с XML файлами.

// Загружает данные приложения из zip архива с XML файлами.
//
// Параметры:
//  ИмяАрхива - Строка - полное имя файла архива с данными,
//  ПараметрыЗагрузки - Структура, содержащая параметры загрузки данных.
//    Ключи:
//      ЗагружаемыеТипы - Массив(ОбъектМетаданных) - массив объектов метаданных, данные
//        которых требуется загрузить из архива. Если значение параметра задано - все прочие
//        данные, содержащиеся в файле выгрузки, загружены не будут. Если значение параметра
//        не задано - будут загружены все данные, содержащиеся в файле выгрузки.
//      ЗагружатьПользователей - Булево - загружать информацию о пользователях информационной базы,
//      ЗагружатьНастройкиПользователей - Булево, игнорируется, если ЗагружатьПользователей = Ложь.
//      СопоставлениеПользователей - ТаблицаЗначений - таблица с колонками:
//        * Пользователь - СправочникСсылка.Пользователи - идентификатора пользователя из архива.
//        * ИдентификаторПользователяСервиса - УникальныйИдентификатор - идентификатор пользователя сервиса.
//        * СтароеИмяПользователяИБ - Строка - старое имя пользователя базы.
//        * НовоеИмяПользователяИБ - Строка - новое имя пользователя базы.
//    Также структура может содержать дополнительные ключи, которые могут быть обработаны внутри
//      произвольных обработчиков загрузки данных.
//
Процедура ЗагрузитьТекущуюОбластьДанныхИзАрхива(Знач ИмяАрхива, Знач ЗагружатьПользователей = Ложь, Знач СвернутьЭлементыСправочникаПользователи = Ложь, СопоставлениеПользователей = Неопределено) Экспорт
	
	ЗагружаемыеТипы = Новый Массив();
	ОбщегоНазначенияКлиентСервер.ДополнитьМассив(ЗагружаемыеТипы, ПолучитьТипыМоделиДанныхОбласти());
	
	Если Не РаботаВМоделиСервисаПовтИсп.РазделениеВключено() Тогда
		ОбщегоНазначенияКлиентСервер.ДополнитьМассив(ЗагружаемыеТипы,
			ВыгрузкаЗагрузкаДанныхСлужебныйСобытия.ПолучитьТипыОбщихДанныхПоддерживающиеСопоставлениеСсылокПриЗагрузке(), Истина);
	КонецЕсли;
	
	ПараметрыЗагрузки = Новый Структура();
	ПараметрыЗагрузки.Вставить("ЗагружаемыеТипы", ЗагружаемыеТипы);
	
	Если РаботаВМоделиСервиса.РазделениеВключено() Тогда
		
		ПараметрыЗагрузки.Вставить("ЗагружатьПользователей", Ложь);
		ПараметрыЗагрузки.Вставить("ЗагружатьНастройкиПользователей", Ложь);
		
	Иначе
		
		ПараметрыЗагрузки.Вставить("ЗагружатьПользователей", ЗагружатьПользователей);
		ПараметрыЗагрузки.Вставить("ЗагружатьНастройкиПользователей", ЗагружатьПользователей);
		
	КонецЕсли;
	
	ПараметрыЗагрузки.Вставить("СвернутьРазделенныхПользователей", СвернутьЭлементыСправочникаПользователи);
	
	Если СопоставлениеПользователей <> Неопределено Тогда
		
		ПараметрыЗагрузки.Вставить("СопоставлениеПользователей", СопоставлениеПользователей);
		
	КонецЕсли;
	
	ВыгрузкаЗагрузкаДанных.ЗагрузитьДанныеИзАрхива(ИмяАрхива, ПараметрыЗагрузки);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЗагрузитьДанныеИзАрхива (БСП)

ОбновитьПараметрыТекущейОбластиДанных (БСП)

ВыполнитьОбновлениеТекущейОбластиДанных (БСП)

ПроверитьПринадлежностьСеансаТекущейОбластиДанных (БСП)

СоздатьЗаданияОчередиПоШаблонамВТекущейОбласти (БСП)

ВыгрузкаВАрхивеСовместимаСТекущейКонфигурацией (БСП)

ЗаблокироватьТекущуюОбластьДанных (БСП)

РазблокироватьТекущуюОбластьДанных (БСП)

УдалитьДанныеПоПодписке (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз