ПослеВыгрузкиОбъекта (БСП)

Автор: 1С
ОбщийМодуль.ВыгрузкаЗагрузкаСовместноРазделенныхДанных
БСП

После выгрузки объекта.

Процедура ПослеВыгрузкиОбъекта(Контейнер, МенеджерВыгрузкиОбъекта, Сериализатор, Объект, Артефакты) Экспорт
	
	СписокСовместноРазделенныхОбъектовМетаданных = ВыгрузкаЗагрузкаСовместноРазделенныхДанныхПовтИсп.СовместноРазделенныеОбъектыМетаданных();
	
	ОбъектНайденВКэше = Ложь;
	
	Для Каждого КлючИЗначение Из СписокСовместноРазделенныхОбъектовМетаданных Цикл
		Для Каждого ИмяОбъектаМетаданных Из КлючИЗначение.Значение.Объекты Цикл
			Если ИмяОбъектаМетаданных = Объект.Метаданные().ПолноеИмя() Тогда
				ОбъектНайденВКэше = Истина;
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
	
	Если Не ОбъектНайденВКэше Тогда
		
		ВызватьИсключение СтрШаблон(
			НСтр("ru = 'Объект метаданных %1 не может быть обработчиком ВыгрузкаСовместноРазделенныхДанных.ПередВыгрузкойОбъекта(),
                  |т.к. отсутствует в кэше совместно-разделенных объектов.
                  |Если после редактирования структуры метаданных конфигурации кэш не обновлялся - необходимо выполнять
                  |обновление кэша совместно-разделенных объектов с помощью вызова метода
                  |ВыгрузкаЗагрузкаСовместноРазделенныхДанных.ЗаполнитьКэшСовместноРазделенныхОбъектов()'", Метаданные.ОсновнойЯзык.КодЯзыка),
			Объект.Метаданные().ПолноеИмя()
		);
		
	КонецЕсли;
	
	МенеджерВыгрузкиОбъекта.ТребуетсяПересоздатьСсылкуПриЗагрузке(Объект.Ссылка);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПослеВыгрузкиОбъекта (БСП)

ПриВыгрузкеОбъекта (БСП)

ПослеВыгрузкиДанных (БСП)

ПередВыгрузкойОбъекта (БСП)

Выгрузка запроса в XML. Выгрузка объекта

ВыгрузкаОбъектаВыборки (БСП)

TurboConf - расширение Конфигуратора 1С