ПередВыгрузкойОбъекта (БСП)

Автор: 1С
ОбщийМодуль.ВыгрузкаЗагрузкаУзловПлановОбменов
БСП

Перед выгрузкой объекта. Для служебного использования.

// Для служебного использования.
//
Процедура ПередВыгрузкойОбъекта(Контейнер, МенеджерВыгрузкиОбъекта, Сериализатор, Объект, Артефакты, Отказ) Экспорт
	
	ОбъектМетаданных = Объект.Метаданные();
	
	Если ОбщегоНазначенияБТС.ЭтоПланОбмена(ОбъектМетаданных) Тогда
		
		// Поддерживается сопоставление ссылок на узлы ЭтотУзел при загрузке данных
		
		Менеджер = ОбщегоНазначения.МенеджерОбъектаПоПолномуИмени(ОбъектМетаданных.ПолноеИмя());
		ЭтотУзел = Менеджер.ЭтотУзел();
		
		Если Объект.Ссылка = ЭтотУзел Тогда
			
			ЕстественныйКлюч = Новый Структура("ЭтотУзел", Истина);
			МенеджерВыгрузкиОбъекта.ТребуетсяСопоставитьСсылкуПриЗагрузке(Объект.Ссылка, ЕстественныйКлюч);
			
		КонецЕсли;
		
		// Выгрузка / загрузка узлов планов обмена не поддерживается.
		
		Отказ = Истина;
		
	Иначе
		
		ВызватьИсключение СтрШаблон(
			НСтр("ru = 'Объект метаданных %1 не может быть обработан обработчиком
                  |ВыгрузкаЗагрузкаУзловПлановОбменов.ПередВыгрузкойОбъекта()!'", Метаданные.ОсновнойЯзык.КодЯзыка),
			Объект.Метаданные().ПолноеИмя()
		);
		
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПередВыгрузкойОбъекта (БСП)

ПослеВыгрузкиОбъекта (БСП)

ПередЗагрузкойОбъекта (БСП)

ПередВыгрузкойНастроек (БСП)

ПередВыгрузкойДанных (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз