НастройкиУчетнойЗаписиПользователя (БСП)

Автор: 1С
ОбщийМодуль.ВызовОнлайнПоддержкиВызовСервера
БСП

Настройки учетной записи пользователя. Получает из регистра сведений параметры для запуска приложения.

// Получает из регистра сведений параметры для запуска приложения.
//
// Параметры:
//		Пользователь  - УникальныйИдентификатор - Текущий пользователь информационной базы.
//
// ВозвращаемоеЗначение:
//		Структура  - Настройки пользователя для запуска приложения.
//
Функция НастройкиУчетнойЗаписиПользователя() Экспорт 
	
	НастройкиПользователя = ВызовОнлайнПоддержки.НастройкиПользователя();
	НастройкиПользователяХранилище = ХранилищеОбщихНастроек.Загрузить("УчетныеЗаписиПользователейВызовОнлайнПоддержки", "НастройкиУчетныхДанных");
	
	Если НЕ НастройкиПользователяХранилище = Неопределено Тогда
		ЗаполнитьЗначенияСвойств(НастройкиПользователя, НастройкиПользователяХранилище);
		Если НастройкиПользователяХранилище.Свойство("ВидимостьКнопки1СБухфон") Тогда
			НастройкиПользователя.ВидимостьКнопкиВызовОнлайнПоддержки = НастройкиПользователяХранилище.ВидимостьКнопки1СБухфон;
		КонецЕсли;
	КонецЕсли;
	
	Возврат НастройкиПользователя;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СохранитьНастройкиПользователяВХранилище (БСП)

ОтправитьФайлыПоПочтеНастройкаУчетнойЗаписиПредложена (БСП)

ДоступноПравоДобавленияУчетныхЗаписей (БСП)

ПроверитьНаличиеУчетнойЗаписиДляОтправкиПочты (БСП)

ПолучитьДоступныеУчетныеЗаписиДляОтправки (БСП)

ЕстьДоступныеУчетныеЗаписиДляОтправки (БСП)

ОтправитьЗагрузитьПочтуПользователя (БСП)

ПользовательЯвляетсяОтветственнымЗаВедениеПапок (БСП)

СистемнаяУчетнаяЗапись (БСП)

TurboConf - расширение Конфигуратора 1С