ИмяПоляДляНаименованияВладельца (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Имя поля для наименования владельца. Возвращает поля для получения наименования владельца, если такой имеется.

// Возвращает поля для получения наименования владельца, если такой имеется.
//
// Параметры:
//  ИмяТаблицы - Строка - Имя основной таблицы, для которой формируется запрос.
//
// Возвращаемое значение:
//  Строка - строка, которая будет вставлена в запрос.
//
Функция ИмяПоляДляНаименованияВладельца(ИмяТаблицы) Экспорт
	
	МассивОписанияКонтактов = ВзаимодействияКлиентСервер.ОписанияКонтактов();
	
	Для каждого ЭлементОписанияМассива Из МассивОписанияКонтактов Цикл
		Если ЭлементОписанияМассива.Имя = ИмяТаблицы И ЭлементОписанияМассива.ЕстьВладелец Тогда
			Возврат "СправочникКонтакт.Владелец.Наименование";
		КонецЕсли;
	КонецЦикла;
	
	Возврат """""";
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ИмяПредопределенногоПоПолям (БСП)

ИмяФормыОбъектаФайловПоВладельцу (БСП)

ИмяСправочникаХраненияФайлов (БСП)

ИмяПоляСоставаДанных (БСП)

ИменаПолейКоллекцииПечатныхФорм (БСП)

СформироватьНаименованиеПредопределенногоУзла (БСП)

ИмяСправочникаХраненияВерсийФайлов (БСП)

ЗаголовкиГиперссылокЗагрузкиДанных (БСП)

ЗаголовкиГиперссылокВыгрузкиДанных (БСП)

TurboConf - расширение Конфигуратора 1С