КорректноВведенНомерТелефона (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Корректно введен номер телефона. Определяет, корректно ли введен номер телефона для сообщения SMS.

// Определяет, корректно ли введен номер телефона для сообщения SMS.
//
// Параметры:
//  НомерТелефона - Строка - строка с номером телефона.
//
// Возвращаемое значение:
//   Булево   - Истина, если номер введен правильно, Ложь в обратном случае.
//
Функция КорректноВведенНомерТелефона(НомерТелефона) Экспорт
	
	СимволыНомера = "+1234567890";
	СимволыРазделители = "()- ";
	
	ФорматированныйНомер = "";
	Для Позиция = 1 По СтрДлина(НомерТелефона) Цикл
		Символ = Сред(НомерТелефона, Позиция, 1);
		Если Символ = "+" И Не ПустаяСтрока(ФорматированныйНомер) Тогда
			Возврат Ложь;
		КонецЕсли;
		Если СтрНайти(СимволыНомера, Символ) > 0 Тогда
			ФорматированныйНомер = ФорматированныйНомер + Символ;
		ИначеЕсли СтрНайти(СимволыРазделители, Символ) = 0 Тогда
			Возврат Ложь;
		КонецЕсли;
	КонецЦикла;
	
	Если ПустаяСтрока(ФорматированныйНомер) Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Если СтрДлина(ФорматированныйНомер) < 3 Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Возврат Истина;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

НомерТелефонаКонтактнойИнформации (БСП)

ПозвонитьПоТелефону (БСП)

ОбновитьНастройкуДобавочногоНомераТелефона (БСП)

НомерТелефонаВСтарыйСписокПолей (БСП)

ЗаполнитьПолучателей (БСП)

ОбновитьТелефон (БСП)

АдресВведенВСвободнойФорме (БСП)

ПроверитьТелефонПоКоду (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз