МассивДочернихУзловСодержащихHTML (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Массив дочерних узлов содержащих html. Получает массив дочерних узлов элемента HTML, содержащих HTML.

// Получает массив дочерних узлов элемента HTML, содержащих HTML.
//
// Параметры:
//  Элемент  - ЭлементHTML
//
// Возвращаемое значение:
//   Массив   - массив дочерних узлов содержащих HTML.
//
Функция МассивДочернихУзловСодержащихHTML(Элемент) Экспорт

	МассивДочернихУзлов = Новый Массив;
	
	Для каждого ДочернийУзел Из Элемент.ДочерниеУзлы Цикл
		
		Если ТипЗнч(ДочернийУзел) = Тип("ЭлементБлокHTML")
			ИЛИ ТипЗнч(ДочернийУзел) = Тип("ЭлементHTML")
			ИЛИ ТипЗнч(ДочернийУзел) = Тип("ТекстDOM")
			ИЛИ ТипЗнч(ДочернийУзел) = Тип("КомментарийDOM")
			ИЛИ ТипЗнч(ДочернийУзел) = Тип("ЭлементТаблицаHTML")
			ИЛИ ТипЗнч(ДочернийУзел) = Тип("ЭлементФорматированногоТекстаHTML") Тогда
			
			МассивДочернихУзлов.Добавить(ДочернийУзел);
			
		КонецЕсли;
		
	КонецЦикла;
	
	Возврат МассивДочернихУзлов;

КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ВставитьЭлементHTMLПервымДочернимЭлементом (БСП)

XML -> Структура/Соответствие (хмл в структуру/соответствие)

ПреобразоватьТаблицуКонтактовВМассив (БСП)

ТаблицуКонтактовВМассив (БСП)

МассивУзловДляРегистрацииВыгружатьПриНеобходимости (БСП)

УзлыПланаОбмена (БСП)

ПолучитьВсеТипыКонфигурации (БСП)

ВыгрузитьКолонку (БСП)

РазностьМассивов (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз