НайтиПоEmail (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Найти по email. Осуществляет поиск контактов по Email или по домену Email.

// Осуществляет поиск контактов по Email или по домену Email.
//
// Параметры:
//  СтрокаПоиска - Строка - служит основой для поиска.
//  ПоДомену     - Булево - признак того, что поиск необходимо осуществлять по домену.
//  Форма        - ФормаКлиентскогоПриложения - Форма, для которой выполняется операция.	
//
// Возвращаемое значение:
//  Булево - Истина, если найден хотя бы один контакт.
//
Функция НайтиПоEmail(СтрокаПоиска, ПоДомену, Форма) Экспорт
	
	Если ПоДомену Тогда
		ТаблицаКонтакты = КонтактыПоДоменномуАдресу(СтрокаПоиска);
	Иначе
		ТаблицаКонтакты = КонтактыПоEmail(СтрокаПоиска);
	КонецЕсли;
	
	Если ТаблицаКонтакты = Неопределено ИЛИ ТаблицаКонтакты.Количество() = 0 Тогда
		Возврат Ложь;
	КонецЕсли;
	
	ЗаполнитьНайденныеКонтакты(ТаблицаКонтакты, Форма.НайденныеКонтакты);
	
	Возврат Истина;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПолучитьВсеКонтактыПоСпискуEmail (БСП)

НайтиСертификат (БСП)

Найти значение в строке

НайтиСтрокиТаблицы (БСП)

НайтиУстановленныеПрограммы (БСП)

Найти основной договор

АдресЭлектроннойПочтыСоответствуетТребованиям (БСП)

РазобратьСтрокуСПочтовымиАдресами (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз