ОбработатьПодменюОтборПоТипуВзаимодействий (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Обработать подменю отбор по типу взаимодействий.

Процедура ОбработатьПодменюОтборПоТипуВзаимодействий(Форма) Экспорт

	ШаблонЗаголовка = НСтр("ru = 'Тип взаимодействий: %1'");
	ПредставлениеТипа = СписокОтборовПоТипуВзаимодействий(Форма.ТолькоПочта).НайтиПоЗначению(Форма.ТипВзаимодействия).Представление;
	Форма.Элементы.СписокТипВзаимодействия.Заголовок = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ШаблонЗаголовка, ПредставлениеТипа);
	Для Каждого ЭлементПодменю Из Форма.Элементы.СписокТипВзаимодействия.ПодчиненныеЭлементы Цикл
		Если ЭлементПодменю.Имя = ("УстановитьОтборТипВзаимодействия_СписокТипВзаимодействия_" + Форма.ТипВзаимодействия) Тогда
			ЭлементПодменю.Пометка = Истина;
		Иначе
			ЭлементПодменю.Пометка = Ложь;
		КонецЕсли;
	КонецЦикла	

КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЗаполнитьПодменюПоТипуВзаимодействия (БСП)

СписокОтборовПоТипуВзаимодействий (БСП)

ПриИзмененииОтбораТипВзаимодействий (БСП)

ПриЗагрузкеТипаВзаимодействийИзНастроек (БСП)

НомерКартинкиПоВзаимодействию (БСП)

ТипВзаимодействияПоИмениКоманды (БСП)

БыстрыйОтборСписокПриИзменении (БСП)

ЗаполнитьПодменюСтатус (БСП)

ОбработатьВыборВПолеРассмотретьПосле (БСП)

TurboConf - расширение Конфигуратора 1С