ОтработатьПризнакИзмененияПометкиУдаленияПриЗаписиПисьма (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Отработать признак изменения пометки удаления при записи письма. Определяет признак изменения пометки удаления при записи письма.

// Определяет признак изменения пометки удаления при записи письма.
//
// Параметры:
//  ПисьмоОбъект  - ДокументОбъект.ЭлектронноеПисьмоИсходящее,
//                  ДокументОбъект.ЭлектронноеПисьмоВходящее - письмо для которого выполняется процедура.
Процедура ОтработатьПризнакИзмененияПометкиУдаленияПриЗаписиПисьма(ПисьмоОбъект) Экспорт
	
	Если ПисьмоОбъект.ПометкаУдаления <> ПисьмоОбъект.ДополнительныеСвойства.ПометкаУдаления Тогда
		Если НЕ ПисьмоОбъект.ДополнительныеСвойства.Свойство("ОбработаноИзменениеПометкиУдаления") Тогда
			Если ПисьмоОбъект.ПометкаУдаления = Истина Тогда
				Папка = ОпределитьПапкуДляПисьмаПоУмолчанию(ПисьмоОбъект.Ссылка);
			Иначе
				Папка = ОпределитьПапкуДляПисьма(ПисьмоОбъект.Ссылка);
			КонецЕсли;
			ВзаимодействияВызовСервера.УстановитьПапкуЭлектронногоПисьма(ПисьмоОбъект.Ссылка, Папка);
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УстановитьСтатусИзмененияПометкиУдаления (БСП)

УстановитьСтатусИзмененияПометкиУдаленияДокумента (БСП)

УстановитьСтатусИзмененияПометкиУдаленияОбъекта (БСП)

УстановитьПометкуУдаленияУВложенийПисьма (БСП)

УстановитьПометкуУдаленияФайловДокументовПередЗаписью (БСП)

УстановитьПометкуУдаленияФайловПередЗаписью (БСП)

ЗапретитьПометкуУдаленияПредопределенныхЭлементовПередЗаписью (БСП)

УстановитьСнятьПометкуУдаленияЗаметок (БСП)

ПриПометкеУдаленияЗадачи (БСП)

TurboConf - расширение Конфигуратора 1С