ПередЗаписьюВзаимодействияИзФормы (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Перед записью взаимодействия из формы. Обработчик события перед записью, возникающих в формах документов взаимодействий.

// Обработчик события перед записью, возникающих в формах документов взаимодействий.
//
// Параметры:
//  Форма         - ФормаКлиентскогоПриложения - форма в которой произошло событие.
//  ТекущийОбъект - ДокументОбъект - документ, в котором возникло событие.
//
Процедура ПередЗаписьюВзаимодействияИзФормы(Форма, ТекущийОбъект, ИзменилисьКонтакты = Ложь) Экспорт
	
	Если НЕ ИзменилисьКонтакты Тогда
		
		ТекущийОбъект.ДополнительныеСвойства.Вставить("НеЗаписыватьКонтакты", Истина);
		
	КонецЕсли;
	
	Если ТекущийОбъект.Ссылка.Пустая() Тогда
		ТекущийОбъект.ВзаимодействиеОснование = Форма.ВзаимодействиеОснование;
	КонецЕсли;

КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПриЗаписиВзаимодействияИзФормы (БСП)

ВзаимодействиеПредметПослеЗаписи (БСП)

ПолныйПутьКФормеПередЗаписьюПередЗаписью (БСП)

ПриЗаписиПредметаИзФормы (БСП)

ПередЗаписьюНаСервере (БСП)

ПередЗаписьюНаСервереФормыРедактированияРазрешенныхЗначений (БСП)

ОбработатьНовыйПароль (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз