ПолучитьКонтактыПоПредмету (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Получить контакты по предмету. Возвращает список контактов предмету по заданному типу контактной информации.

// Возвращает список контактов предмету по заданному типу контактной информации.
//
Функция ПолучитьКонтактыПоПредмету(Предмет, ТипыКонтактнойИнформации) Экспорт
	
	ПолучателиПисьма = Новый Массив;
	Если ВзаимодействияКлиентСервер.ЯвляетсяПредметом(Предмет)
		ИЛИ ВзаимодействияКлиентСервер.ЯвляетсяВзаимодействием(Предмет) Тогда
		
		МенеджерОбъекта = ОбщегоНазначения.МенеджерОбъектаПоСсылке(Предмет);
		Контакты = МенеджерОбъекта.ПолучитьКонтакты(Предмет);
		
		Если Контакты <> Неопределено Тогда
			Для каждого СтрокаТаблицы Из Контакты Цикл
				
				Получатель = Новый Структура("Контакт, Представление, Адрес");
				Получатель.Контакт = ?(ТипЗнч(СтрокаТаблицы) = Тип("Структура"), СтрокаТаблицы.Контакт, СтрокаТаблицы);
				
				ДозаполнитьПоляКонтактов(Получатель.Контакт, Получатель.Представление,
					Получатель.Адрес, ТипыКонтактнойИнформации);
				
				ПолучателиПисьма.Добавить(Получатель);
				
			КонецЦикла;
		КонецЕсли;
		
	КонецЕсли;
	
	Возврат ПолучателиПисьма;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЗаполнитьКонтактыПоПредмету (БСП)

ПриПоискеКонтактов (БСП)

ПолучитьЗначениеПредмета (БСП)

ВыполнитьПолныйПерерасчетСостояний (БСП)

РассчитыватьРассмотрено (БСП)

ТекстЗапросаПоискКонтактовПоПредмету (БСП)

ПолучитьВсеКонтактыПоСпискуEmail (БСП)

ПолучитьВсеКонтактыПоТелефону (БСП)

ПолучитьАдресаЭлектроннойПочтыКонтакта (БСП)

TurboConf - расширение Конфигуратора 1С