ПолучитьПредставленияПолучателейВходящегоПисьма (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Получить представления получателей входящего письма. Получает представление получателей входящего письма.

// Получает представление получателей входящего письма.
//
// Параметры:
//  ТаблицаПолучателей  - ТабличнаяЧасть - табличная часть для которой выполняется функция.
//
// Возвращаемое значение:
//   СтрокаКВозврату   - строка с представление всех получателей табличной части.
//
Функция ПолучитьПредставленияПолучателейВходящегоПисьма(ТаблицаПолучателей) Экспорт

	СтрокаКВозврату = "";
	
	Для Каждого Получатель Из ТаблицаПолучателей Цикл
		
		СтрокаКВозврату = СтрокаКВозврату + "'" 
		         + ?(ПустаяСтрока(Получатель.Представление), Получатель.Адрес, Получатель.Представление + "<"+ Получатель.Адрес+">") + "'"+ ", ";
		
	КонецЦикла;
	
	Если Не ПустаяСтрока(СтрокаКВозврату) Тогда
		
		СтрокаКВозврату = Лев(СтрокаКВозврату,СтрДлина(СтрокаКВозврату) - 2);
		
	КонецЕсли;
	
	Возврат СтрокаКВозврату;

КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПолучитьПараметрыРаботыПользователяДляВходящегоЭлектронногоПисьма (БСП)

ПредставлениеПисьма (БСП)

СформироватьТекстHTMLДляВходящегоПисьма (БСП)

ПолучитьДанныеПисьмаОснования (БСП)

ПолучитьВложенияЭлектронногоПисьма (БСП)

ТаблицаТиповПолучателей (БСП)

ПолучитьПредставлениеТелефона (БСП)

ПолучитьПапкуЭлектронногоПисьма (БСП)

ПолучитьВложенияПисьмаСНеПустымИД (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз