ПослеУдаленияПомеченных (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

После удаления помеченных. Вызывается после удаления помеченных объектов.

// Вызывается после удаления помеченных объектов.
//
// Параметры:
//   ПараметрыВыполнения - Структура - Контекст удаления помеченных объектов.
//       * Удаленные - Массив - Ссылки удаленных объектов.
//       * НеУдаленные - Массив - Ссылки объектов, которые не получилось удалить.
//
Процедура ПослеУдаленияПомеченных(ПараметрыВыполнения) Экспорт
	
	ТребуетсяПересчетСостояний = Ложь;
	
	Для Каждого УдаленнаяСсылка Из ПараметрыВыполнения.Удаленные Цикл
		
		Если ВзаимодействияКлиентСервер.ЯвляетсяВзаимодействием(УдаленнаяСсылка) Тогда
			ТребуетсяПересчетСостояний = Истина;
			Прервать;
		КонецЕсли;
		
	КонецЦикла;
	
	Если ТребуетсяПересчетСостояний Тогда
		
		ВыполнитьПолныйПерерасчетСостояний();
		
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

НачатьУдалениеПомеченных (БСП)

ПередПоискомПомеченныхНаУдаление (БСП)

УдалениеПомеченныхПоРасписанию (БСП)

ЗначениеФлажкаУдалятьПоРасписанию (БСП)

ВключитьУдалениеПомеченныхОбъектов (БСП)

УстановитьРежимУдалятьПоРасписанию (БСП)

ПослеУдаленияПользователяИнформационнойБазы (БСП)

ОбработатьФайлПослеУдаленияФайлов (БСП)

УдалитьФайлИзРабочегоКаталогаПослеУдаленияФайла (БСП)

TurboConf - расширение Конфигуратора 1С