ПриЗагрузкеТипаВзаимодействийИзНастроек (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

При загрузке типа взаимодействий из настроек. Выполняется при загрузке сохраненных пользовательских настроек быстрого отбора ТипВзаимодействия

// Выполняется при загрузке сохраненных пользовательских настроек быстрого отбора ТипВзаимодействия 
// в формах списков документов взаимодействий.
//
// Параметры:
//  Форма - ФормаКлиентскогоПриложения - форма для которой выполняется процедура.
//  Настройки - Соответствие - загружаемые настройки.
//
Процедура ПриЗагрузкеТипаВзаимодействийИзНастроек(Форма, Настройки) Экспорт

	ТипВзаимодействия = Настройки.Получить("ТипВзаимодействия");
	Если ТипВзаимодействия <> Неопределено Тогда
		Настройки.Удалить("ТипВзаимодействия");
	КонецЕсли;
	
	Если Форма.ТолькоПочта Тогда
		Если ТипВзаимодействия = Неопределено 
			ИЛИ Форма.Элементы.ТипВзаимодействия.СписокВыбора.НайтиПоЗначению(ТипВзаимодействия) = Неопределено Тогда
			ТипВзаимодействия = "ВсеПисьма";
			Настройки.Удалить("ТипВзаимодействия");
		КонецЕсли;
	Иначе
		Если ТипВзаимодействия = Неопределено Тогда
			ТипВзаимодействия = "Все";
			Настройки.Удалить("ТипВзаимодействия");
		КонецЕсли;
	КонецЕсли;
	
	Форма.ТипВзаимодействия = ТипВзаимодействия;

КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПередЗагрузкойНастроек (БСП)

НомерКартинкиПоВзаимодействию (БСП)

ЗаполнитьПодменюПоТипуВзаимодействия (БСП)

ОбработатьПодменюОтборПоТипуВзаимодействий (БСП)

СписокОтборовПоТипуВзаимодействий (БСП)

ТипВзаимодействияПоИмениКоманды (БСП)

ПриИзмененииОтбораТипВзаимодействий (БСП)

ПередЗагрузкойНастроекВКомпоновщик (БСП)

TurboConf - расширение Конфигуратора 1С