РезультатФорматированияНомераДляОтправки (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Результат форматирования номера для отправки.

Функция РезультатФорматированияНомераДляОтправки(Номер) Экспорт
	
	Результат = "";
	ДопустимыеСимволы = "+1234567890";
	Для Позиция = 1 По СтрДлина(Номер) Цикл
		Символ = Сред(Номер,Позиция,1);
		Если СтрНайти(ДопустимыеСимволы, Символ) > 0 Тогда
			Результат = Результат + Символ;
		КонецЕсли;
	КонецЦикла;
	
	Если СтрДлина(Результат) > 10 Тогда
		ПервыйСимвол = Лев(Результат, 1);
		Если ПервыйСимвол = "8" Тогда
			Результат = "+7" + Сред(Результат, 2);
		ИначеЕсли ПервыйСимвол <> "+" Тогда
			Результат = "+" + Результат;
		КонецЕсли;
	КонецЕсли;
	
	Возврат Результат;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ФорматированиеРезультатовАвтоподбора (БСП)

РезультатОтправкиПолученияПочтыПользователя (БСП)

ЗаполнитьШаблон (БСП)

ПолеРезультат (БСП)

ОповещениеБезРезультата (БСП)

ВерсияКонфигурацииБезНомераСборки (БСП)

НомерТелефонаКонтактнойИнформации (БСП)

TurboConf - расширение Конфигуратора 1С