СформироватьСписокУчастников (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Сформировать список участников. Формирует строку-представление списка участников взаимодействия.

// Формирует строку-представление списка участников взаимодействия.
//
// Параметры:
//  Объект - ДокументОбъект - документ, на основании табличной части участники которого формируется строка.
//
Процедура СформироватьСписокУчастников(Объект) Экспорт
	
	Если  ТипЗнч(Объект) = Тип("ДокументОбъект.СообщениеSMS") Тогда
		ИмяТаблицы = "Адресаты";
	Иначе 
		ИмяТаблицы = "Участники";
	КонецЕсли;
	
	Объект.СписокУчастников = "";
	Для Каждого Участник Из Объект[ИмяТаблицы] Цикл
		Объект.СписокУчастников = Объект.СписокУчастников + ?(Объект.СписокУчастников = "", "", "; ") + Участник.ПредставлениеКонтакта;
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СтраныУчастникиЕАЭС (БСП)

СформироватьСписокФайловДляОтправкиПоПочте (БСП)

СформироватьСписокВсехНовостей (БСП)

СформироватьСписокНовостейНаРабочийСтол (БСП)

СформироватьСписокПолучателейРассылки (БСП)

СформироватьСписокТекущихДелПользователя (БСП)

СформироватьСписокРеквизитовПоСКД (БСП)

СформироватьДанныеВыбораИсполнителя (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз